2011年6月16日木曜日

雇用の常識「本当に見えるウソ」


このエントリーをはてなブックマークに追加


雇用の常識「本当に見えるウソ」


TVのコメンテーターがまるで事実のように語る雇用情勢についての検証本。元々転職活動する前に買ってずっと積まれてたのを読んでみた。

内容はまあおもしろい。読んでて興味深かったのが他人の意見に対していかにデータを活用して論理的に反論していくかというプロセス。データを用いた論理構築のサンプル集としてとても良いと思った。

この本ではTVによって世間一般に広められた「確証は無いけど何となく定着している」概念に対して既存のデータを様々な角度で考察することにより実にわかりやすく反論をしている。

文章の書き方も論文の手本のような感じでおもしろみは無いけどわかりやすい。


2011年6月9日木曜日

CL clack & cl-markup GET/POST/SESSION


このエントリーをはてなブックマークに追加


Clackをもう少し。Webで必須なデータの受け渡し部分について試してみた。

cl-markupはcl-whoと挙動が違うので使うときは注意が必要。



2011年6月8日水曜日

RHEL6.1 の気になるアップデート


このエントリーをはてなブックマークに追加


気が付いたらRHEL6.1がリリースされていた。リリースノートを眺めてみて気になるアップデートをピックアップ。

試してみたい方はRHNetworkからISOイメージがダウンロードできます。 → RedHat Network を無料で使う方法



ITインフラ/基盤エンジニア アンケート2011 簡易集計


このエントリーをはてなブックマークに追加


ITインフラ/基盤エンジニア アンケート2011

皆様からの多数のご回答ありがとうございます。大変貴重なデータを集めることができました。取り急ぎ簡易的な集計結果を掲載いたします。

時間のあるときにもう少しデータ間の相関関係を分析してみたいと思います。

*有効回答数48名



2011年6月7日火曜日

CL clack & cl-markup


このエントリーをはてなブックマークに追加


Common Lispで書かれたシンプルなWebサーバとタグビルダー(?)。試行錯誤しながらちょっと使ってみた。

http://e-arrows.sakura.ne.jp/2011/05/what-ive-created-in-ariel.html



2011年6月2日木曜日

CL で Livedoor Blog へ投稿


このエントリーをはてなブックマークに追加


変数にID、API Key、自分のブログ用AtomPubエンドポイントを設定すれば使える(はず



2011年6月1日水曜日

Bloggerの埋め込みコメントフォームを復活させる


このエントリーをはてなブックマークに追加


5月13日前後に起きたBloggerの大規模障害からBloggerの埋め込みコメントフォームが表示されなくなってしまった。

これを復活させる方法を見つけたのでメモ。
http://www.google.vu/support/forum/p/blogger/thread?tid=12a42809166b40d3&hl=en



Common Lisp で WSSE認証


このエントリーをはてなブックマークに追加


Win7 64 + Clozure CL

Hatenaはうまくいくけど、Livedoorは上手くいかなかった・・・何でだろう?

間違ってたので修正。Livedoorも上手くいくようになった。



Hash Digest の算出


このエントリーをはてなブックマークに追加


ironclad というパッケージを使う。quicklispから簡単にインストール可能。

文字列のハッシュ例
CL-USER> (ironclad:byte-array-to-hex-string
               (ironclad:digest-sequence :sha1
                  (ironclad:ascii-string-to-byte-array "password")))

"5baa61e4c9b93f3f0682250b6cf8331b7ee68fd8"

抜粋
・Supported ciphers: AES, DES, 3DES, Blowfish, Twofish, RC5, RC6, Arcfour (RC4)
・Supported hash functions: MD4, MD5, SHA1, SHA256, Tiger, Adler32, CRC32 (also supports tree hashes)
・RFC2104 HMACs and RFC4493 CMACs
・Public key schemes: DSA signing and verification
・Key derivation functions: PBKDF1, PBKDF2 (RFC 2898)


NTEmacsのデフォルトブラウザをChromeに変更


このエントリーをはてなブックマークに追加


WindowsではNTEmacsからURLを開くときに標準でOS規定のデフォルトブラウザが使われる。通常はもちろんIE。それをChromeに変更するには以下を.emacsへ追記する。パスは自分の環境に合わせて編集が必要。

もちろんOSのデフォルトブラウザを変更してもいいけど、IEじゃないと困ることもあるのでEmacs内でのみ有効になるようにしてみた。

;; デフォルトブラウザをChromeへ
(defvar *chrome-path* "C:/Users/win7-u24/AppData/Local/Google/Chrome/Application/chrome.exe")
(setq browse-url-browser-function
      '(("."        . browse-url-generic)))
(setq browse-url-generic-program *chrome-path*)